#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\|\|(?:\h+\d+\h+\|\|)+$"
Local $sString = "न च <तुल्य-गुणः>K1 दूष्यः न दोषः प्रकृतिः भवेत्|| 11 ||" & @CRLF & _
"उक्ताः महाचतुष्पादे येषु आयत्तं <भिषक्-जितम्>T3|| 24 ||"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)