import re
regex = re.compile(r"\|\|(?:\h+\d+\h+\|\|)+$", flags=re.MULTILINE)
test_str = ("न च <तुल्य-गुणः>K1 दूष्यः न दोषः प्रकृतिः भवेत्|| 11 ||\n"
"उक्ताः महाचतुष्पादे येषु आयत्तं <भिषक्-जितम्>T3|| 24 ||")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)