const regex = /\|\|(?:\h+\d+\h+\|\|)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\|\\|(?:\\h+\\d+\\h+\\|\\|)+$', 'gm')
const str = `न च <तुल्य-गुणः>K1 दूष्यः न दोषः प्रकृतिः भवेत्|| 11 ||
उक्ताः महाचतुष्पादे येषु आयत्तं <भिषक्-जितम्>T3|| 24 ||`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);