re = /\|\|(?:\h+\d+\h+\|\|)+$/m
str = 'न च <तुल्य-गुणः>K1 दूष्यः न दोषः प्रकृतिः भवेत्|| 11 ||
उक्ताः महाचतुष्पादे येषु आयत्तं <भिषक्-जितम्>T3|| 24 ||'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result