$re = '/\|\|(?:\h+\d+\h+\|\|)+$/m';
$str = 'न च <तुल्य-गुणः>K1 दूष्यः न दोषः प्रकृतिः भवेत्|| 11 ||
उक्ताः महाचतुष्पादे येषु आयत्तं <भिषक्-जितम्>T3|| 24 ||';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;