using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)(\bfirstname=rahman\b)(.*)(\blastname=mahmoodi\b)(.*)(\bcountry=canada\b)(.*)";
string input = @"firstname=rahman, middlename=abdul, lastname=mahmoodi, country=australia
firstname=rahman, middlename=james, lastname=mahmoodi, country=canada
firstname=rahman, middlename=james, lastname=mahmoodi, country=new zealand";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}