re = /(.*)(\bfirstname=rahman\b)(.*)(\blastname=mahmoodi\b)(.*)(\bcountry=canada\b)(.*)/
str = 'firstname=rahman, middlename=abdul, lastname=mahmoodi, country=australia
firstname=rahman, middlename=james, lastname=mahmoodi, country=canada
firstname=rahman, middlename=james, lastname=mahmoodi, country=new zealand'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end