// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.*)(\bfirstname=rahman\b)(.*)(\blastname=mahmoodi\b)(.*)(\bcountry=canada\b)(.*)").unwrap();
let string = "firstname=rahman, middlename=abdul, lastname=mahmoodi, country=australia
firstname=rahman, middlename=james, lastname=mahmoodi, country=canada
firstname=rahman, middlename=james, lastname=mahmoodi, country=new zealand";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}