package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*)(\bfirstname=rahman\b)(.*)(\blastname=mahmoodi\b)(.*)(\bcountry=canada\b)(.*)`)
var str = `firstname=rahman, middlename=abdul, lastname=mahmoodi, country=australia
firstname=rahman, middlename=james, lastname=mahmoodi, country=canada
firstname=rahman, middlename=james, lastname=mahmoodi, country=new zealand`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}