# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d{4}-\d{1,2}-\d{1,2})_(\d{2}-\d{2}-\d{2}).*\.(\d+)//gm;t' <<< "Toolx-2022-01-18_15-26-09.blf.26
Temperaturelow-2022-01-18_15-26-09.blf.27
Temperaturehigh2022-01-18_15-26-09.blf.28
low2022-01-18_15-26-09.blf.29
high2022-01-18_15-26-09.blf.30"