#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d{4}-\d{1,2}-\d{1,2})_(\d{2}-\d{2}-\d{2}).*\.(\d+)"
Local $sString = "Toolx-2022-01-18_15-26-09.blf.26" & @CRLF & _
"Temperaturelow-2022-01-18_15-26-09.blf.27" & @CRLF & _
"Temperaturehigh2022-01-18_15-26-09.blf.28" & @CRLF & _
"low2022-01-18_15-26-09.blf.29" & @CRLF & _
"high2022-01-18_15-26-09.blf.30"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)