// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d{4}-\d{1,2}-\d{1,2})_(\d{2}-\d{2}-\d{2}).*\.(\d+)").unwrap();
let string = "Toolx-2022-01-18_15-26-09.blf.26
Temperaturelow-2022-01-18_15-26-09.blf.27
Temperaturehigh2022-01-18_15-26-09.blf.28
low2022-01-18_15-26-09.blf.29
high2022-01-18_15-26-09.blf.30";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}