import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{4}-\\d{1,2}-\\d{1,2})_(\\d{2}-\\d{2}-\\d{2}).*\\.(\\d+)";
final String string = "Toolx-2022-01-18_15-26-09.blf.26\n"
+ "Temperaturelow-2022-01-18_15-26-09.blf.27\n"
+ "Temperaturehigh2022-01-18_15-26-09.blf.28\n"
+ "low2022-01-18_15-26-09.blf.29\n"
+ "high2022-01-18_15-26-09.blf.30";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}