import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^\\b.*(^(?!SERIAL|TT).+)";
final String string = "CONT NEG TESTS - ALL PINS\n\n"
+ "SERIAL NUMBER: 15 MODULE: 0 Mon Jan 1 03:41:42 2007\n"
+ "TT STMT PIN MEAS VALUE FORCING LESS THAN GREATER THAN\n"
+ "---- ---- --- --------------- --------------- ---------- ------------";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}