#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\w+[-_]{0,1}\w+"
Local $sString = "alabaster==0.7.9" & @CRLF & _
"blow_ster==1.2.3" & @CRLF & _
"brewster-ify==2.3.4" & @CRLF & _
"filler_==8.2.1" & @CRLF & _
"arrow==0.8.0" & @CRLF & _
"awesome-slugify==1.6.5" & @CRLF & _
"Babel==2.3.4" & @CRLF & _
"binaryornot==0.4.0" & @CRLF & _
"blessings==1.6"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")