$re = '/\w+[-_]{0,1}\w+/';
$str = 'alabaster==0.7.9
blow_ster==1.2.3
brewster-ify==2.3.4
filler_==8.2.1
arrow==0.8.0
awesome-slugify==1.6.5
Babel==2.3.4
binaryornot==0.4.0
blessings==1.6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);