import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+[-_]{0,1}\\w+";
final String string = "alabaster==0.7.9\n"
+ "blow_ster==1.2.3\n"
+ "brewster-ify==2.3.4\n"
+ "filler_==8.2.1\n"
+ "arrow==0.8.0\n"
+ "awesome-slugify==1.6.5\n"
+ "Babel==2.3.4\n"
+ "binaryornot==0.4.0\n"
+ "blessings==1.6";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}