const regex = /\w+[-_]{0,1}\w+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w+[-_]{0,1}\\w+', 'g')
const str = `alabaster==0.7.9
blow_ster==1.2.3
brewster-ify==2.3.4
filler_==8.2.1
arrow==0.8.0
awesome-slugify==1.6.5
Babel==2.3.4
binaryornot==0.4.0
blessings==1.6`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}