# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\w+[-_]{0,1}\w+"
test_str = ("alabaster==0.7.9\n"
"blow_ster==1.2.3\n"
"brewster-ify==2.3.4\n"
"filler_==8.2.1\n"
"arrow==0.8.0\n"
"awesome-slugify==1.6.5\n"
"Babel==2.3.4\n"
"binaryornot==0.4.0\n"
"blessings==1.6")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.