const regex = /\d{2}-\d{2}-\d{4}\s\d{2}:\d{2}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{2}-\\d{2}-\\d{4}\\s\\d{2}:\\d{2}', 'gm')
const str = `jahid 19-06-2022 12:37 19-06-2022 12:37`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);