#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/\*[\s\S]*?\*\/|{[^{}]*?}"
Local $sString = "int j=100;" & @CRLF & _
"/* comment needs to be removed*/" & @CRLF & _
"int c = 200;" & @CRLF & _
"" & @CRLF & _
"if (c > 200) {" & @CRLF & _
" c = 100;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"/*" & @CRLF & _
"*comment needs to be removed " & @CRLF & _
"*/" & @CRLF & _
"" & @CRLF & _
"count = count + 1;" & @CRLF & _
"" & @CRLF & _
"{comment needs to be removed}" & @CRLF & _
"" & @CRLF & _
"i++;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")