re = /\/\*[\s\S]*?\*\/|{[^{}]*?}/m
str = 'int j=100;
/* comment needs to be removed*/
int c = 200;
if (c > 200) {
c = 100;
}
/*
*comment needs to be removed
*/
count = count + 1;
{comment needs to be removed}
i++;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end