$re = '/\/\*[\s\S]*?\*\/|{[^{}]*?}/m';
$str = 'int j=100;
/* comment needs to be removed*/
int c = 200;
if (c > 200) {
c = 100;
}
/*
*comment needs to be removed
*/
count = count + 1;
{comment needs to be removed}
i++;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);