package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/\*[\s\S]*?\*\/|{[^{}]*?}`)
var str = `int j=100;
/* comment needs to be removed*/
int c = 200;
if (c > 200) {
c = 100;
}
/*
*comment needs to be removed
*/
count = count + 1;
{comment needs to be removed}
i++;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}