// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/\*[\s\S]*?\*\/|{[^{}]*?}").unwrap();
let string = "int j=100;
/* comment needs to be removed*/
int c = 200;
if (c > 200) {
c = 100;
}
/*
*comment needs to be removed
*/
count = count + 1;
{comment needs to be removed}
i++;";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}