# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<[^>]*\sstyle=)"([^"]+)"([^>]*>)/\1\\"\2\\"\3/gm;t' <<< "Améliorer <span style=\"color:black;\">mon authentification</span>
"