import Foundation
let pattern = #"(<[^>]*\sstyle=)"([^"]+)"([^>]*>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Améliorer <span style="color:black;">mon authentification</span>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\\"\2\\"\3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)