package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<[^>]*\sstyle=)"([^"]+)"([^>]*>)`)
var str = `Améliorer <span style="color:black;">mon authentification</span>
`
var substitution = "\1\\"\2\\"\3"
fmt.Println(re.ReplaceAllString(str, substitution))
}