use strict;
my $str = 'Améliorer <span style="color:black;">mon authentification</span>
';
my $regex = qr/(<[^>]*\sstyle=)"([^"]+)"([^>]*>)/mp;
my $subst = '\\1\\\\"\\2\\\\"\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";