using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" *""(\w+)"": ""?(\w*)""?,";
string input = @" ""Status"": 1,
""OrderBy"": 5,
""ParentID"": 0,
""SortOrderBy"": 5,
""Description"": "",
""level"": 1,
""ProjectID"": 1,
""ParentIDStr"": ""0"",
""leaf"": false,
""type"": ""building"",
""Name"": ""小浪底水利枢纽"",
""Remark"": "",
""SiteNames"": ""小浪底水利枢纽"",
""expanded"": true,
""PLevel"": 1,
""ID"": 1,
""id"": ""1-1"",
""text"": ""小浪底水利枢纽"",
""iconCls"": ""buildingCls"",
""nodeID"": 1,";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}