import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " *\"(\\w+)\": \"?(\\w*)\"?,";
final String string = " \"Status\": 1,\n"
+ " \"OrderBy\": 5,\n"
+ " \"ParentID\": 0,\n"
+ " \"SortOrderBy\": 5,\n"
+ " \"Description\": \"\",\n"
+ " \"level\": 1,\n"
+ " \"ProjectID\": 1,\n"
+ " \"ParentIDStr\": \"0\",\n"
+ " \"leaf\": false,\n"
+ " \"type\": \"building\",\n"
+ " \"Name\": \"小浪底水利枢纽\",\n"
+ " \"Remark\": \"\",\n"
+ " \"SiteNames\": \"小浪底水利枢纽\",\n"
+ " \"expanded\": true,\n"
+ " \"PLevel\": 1,\n"
+ " \"ID\": 1,\n"
+ " \"id\": \"1-1\",\n"
+ " \"text\": \"小浪底水利枢纽\",\n"
+ " \"iconCls\": \"buildingCls\",\n"
+ " \"nodeID\": 1,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}