// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m) *"(\w+)": "?(\w*)"?,"#).unwrap();
let string = " \"Status\": 1,
\"OrderBy\": 5,
\"ParentID\": 0,
\"SortOrderBy\": 5,
\"Description\": \"\",
\"level\": 1,
\"ProjectID\": 1,
\"ParentIDStr\": \"0\",
\"leaf\": false,
\"type\": \"building\",
\"Name\": \"小浪底水利枢纽\",
\"Remark\": \"\",
\"SiteNames\": \"小浪底水利枢纽\",
\"expanded\": true,
\"PLevel\": 1,
\"ID\": 1,
\"id\": \"1-1\",
\"text\": \"小浪底水利枢纽\",
\"iconCls\": \"buildingCls\",
\"nodeID\": 1,";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}