use strict;
my $str = ' "Status": 1,
"OrderBy": 5,
"ParentID": 0,
"SortOrderBy": 5,
"Description": "",
"level": 1,
"ProjectID": 1,
"ParentIDStr": "0",
"leaf": false,
"type": "building",
"Name": "小浪底水利枢纽",
"Remark": "",
"SiteNames": "小浪底水利枢纽",
"expanded": true,
"PLevel": 1,
"ID": 1,
"id": "1-1",
"text": "小浪底水利枢纽",
"iconCls": "buildingCls",
"nodeID": 1,';
my $regex = qr/ *"(\w+)": "?(\w*)"?,/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}