const regex = / *"(\w+)": "?(\w*)"?,/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' *"(\\w+)": "?(\\w*)"?,', 'gm')
const str = ` "Status": 1,
"OrderBy": 5,
"ParentID": 0,
"SortOrderBy": 5,
"Description": "",
"level": 1,
"ProjectID": 1,
"ParentIDStr": "0",
"leaf": false,
"type": "building",
"Name": "小浪底水利枢纽",
"Remark": "",
"SiteNames": "小浪底水利枢纽",
"expanded": true,
"PLevel": 1,
"ID": 1,
"id": "1-1",
"text": "小浪底水利枢纽",
"iconCls": "buildingCls",
"nodeID": 1,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}