package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)--(?<myfield>[^-\n]+)--`)
var str = `10.231.247.162--WTLDNDAA001--Can't ping DSLAM
10.44.69.250--TCSUAZMS--VisibilityOnly--Can't ping DSLAM
10.44.69.250--TCSUAZMS--Can't ping DSLAM--VisibilityOnly
172.31.247.148--CLSPCO32H01.2--Can't ping DSLAM
172.31.166.155--RSBGORBU--Can't ping DSLAM `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}