# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"--(?<myfield>[^-\n]+)--"
test_str = ("10.231.247.162--WTLDNDAA001--Can't ping DSLAM\n"
"10.44.69.250--TCSUAZMS--VisibilityOnly--Can't ping DSLAM \n"
"10.44.69.250--TCSUAZMS--Can't ping DSLAM--VisibilityOnly \n"
"172.31.247.148--CLSPCO32H01.2--Can't ping DSLAM \n"
"172.31.166.155--RSBGORBU--Can't ping DSLAM ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.