import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "--(?<myfield>[^-\\n]+)--";
final String string = "10.231.247.162--WTLDNDAA001--Can't ping DSLAM\n"
+ "10.44.69.250--TCSUAZMS--VisibilityOnly--Can't ping DSLAM \n"
+ "10.44.69.250--TCSUAZMS--Can't ping DSLAM--VisibilityOnly \n"
+ "172.31.247.148--CLSPCO32H01.2--Can't ping DSLAM \n"
+ "172.31.166.155--RSBGORBU--Can't ping DSLAM ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}