# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d+(?:\.\d+)?p?x?/*/gm;t' <<< "2pxy...12py...12px...12ppx...12...12ypx"