package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+(?:\.\d+)?p?x?`)
var str = `2pxy...12py...12px...12ppx...12...12ypx`
var substitution = "*"
fmt.Println(re.ReplaceAllString(str, substitution))
}