use strict;
my $str = '2pxy...12py...12px...12ppx...12...12ypx';
my $regex = qr/\d+(?:\.\d+)?p?x?/mp;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";