const regex = /\d+(?:\.\d+)?p?x?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+(?:\\.\\d+)?p?x?', 'gm')
const str = `2pxy...12py...12px...12ppx...12...12ypx`;
const subst = `*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);