#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?m)^go\s*$"
Local $sString = "aago go sdf" & @CRLF & _
"bbbgo go sdf gojh" & @CRLF & _
"go" & @CRLF & _
"" & @CRLF & _
"zzzz bbb" & @CRLF & _
"go" & @CRLF & _
"" & @CRLF & _
"sdkfgo go sdfd" & @CRLF & _
"go" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")