import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^go\\s*$";
final String string = "aago go sdf\n"
+ "bbbgo go sdf gojh\n"
+ "go\n\n"
+ "zzzz bbb\n"
+ "go\n\n"
+ "sdkfgo go sdfd\n"
+ "go\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}