const regex = new RegExp('(?m)^go\\s*$', 'gi')
const str = `aago go sdf
bbbgo go sdf gojh
go
zzzz bbb
go
sdkfgo go sdfd
go
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}