re = /(?m)^go\s*$/i
str = 'aago go sdf
bbbgo go sdf gojh
go
zzzz bbb
go
sdkfgo go sdfd
go
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end