package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?m)^go\s*$`)
var str = `aago go sdf
bbbgo go sdf gojh
go
zzzz bbb
go
sdkfgo go sdfd
go
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}