using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\""([^\""]*)\"")|(?:\'([^\']*)\')$";
string substitution = @"$1peter file$2";
string input = @"""ajdojsd 'adas'""
'adaodpkosad"" ""'
'hello' ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}