package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\"([^\"]*)\")|(?:\'([^\']*)\')$`)
var str = `"ajdojsd 'adas'"
'adaodpkosad" "'
'hello' `
var substitution = "$1peter file$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}