const regex = new RegExp('^(?:\\"([^\\"]*)\\")|(?:\\\\'([^\\\\']*)\\\\')$', 'gm')
const str = `"ajdojsd 'adas'"
'adaodpkosad" "'
'hello' `;
const subst = `$1peter file$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);