import Foundation
let pattern = #"^(?:\"([^\"]*)\")|(?:\'([^\']*)\')$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"ajdojsd 'adas'"
'adaodpkosad" "'
'hello'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1peter file$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)